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Introduction 

The ANPR Demo for Images (ADI) is a program that was developed by Adaptive Recognition Hungary 

to serve as a simple and versatile tool for evaluating our core LPR technology before having to first 

develop an application.  

The goal of the SDK is to allow you to develop a similar or even a more complicated application based 

on the Carmen API in order to meet the exact requirements of the particular project where it will be 

deployed. 

 

The demo can handle both a single image as well as an image directory as an input source. 

Supported image formats: .jpg, .jpeg, .png, .bmp, .jp2 

 

This application can be found in the following folder: 

- On Windows: “c:\Program Files\Adaptive Recognition\CARMEN softwares\Demos\ADI\” 

- On Linux: “\opt\gx64\ADI_Demo\” 

 

Not all images are adequate for ANPR, the input images must meet a specific set of criteria for the 

engine to be able to recognize them. Please study the following document to learn more about these 

requirements: Imaging for Carmen®. 

 

 

 

  

 
 

Please note, that this application is not available for ARM and CentOS6 packages on Linux. 

https://adaptiverecognition.com/app/uploads/DOC/Software/Carmen/brief_guide_for_input_images.pdf
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Main Screen 

After starting the demo, you will be presented with the main screen of the application. This window is 

split into three separate sections; the Result Image, the Result Tree and the Log sections. All three 

sections provide information in connection with the scanned image.  

 
Quick overview of the main screen 

 
In the title you can see the following information: 
 

 
 

ANPR: the currently used ANPR engine region and version 
MMR: the currently used MMR engine region and version 
License: showing where CARMEN® is looking for the licenses (local/network) 
 

 
 

   

 

In case of missing hardware key, the following error message will appear: 
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File Menu 

The ADI menu bar consists of four menu buttons, located in the upper left corner of the program 

window as follows: 

File, Edit, Process, and Help. 

 

 
 

The File menu contains the following menu items:  

 

Open Image(s) 

Click to select specific images for LPR processing. 

 

Open Directory 

Click to specify a directory containing images for LPR processing. 

 

Save Log 

Click to save the results log manually. The log can also be saved automatically by adjusting the 

Demo Preferences under the Edit menu. 
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Edit Menu 

The Edit menu contains the following menu items:  

 

 

ANPR / MMR Settings 

Contains various configuration options related to the ANPR / MMR 

process. The engine used for processing is also selected here. 

By clicking this menu item, the following pop-up window will 

appear: 

 

Engine: Click the drop-down menu to select an engine from the list 

of installed engines. 

 

Properties: Lists the property values for the selected engine. To 

adjust the pre-set values, click on one of the value fields and then 

input a desired value. A full description of the engine properties can 

be found in the CARMEN® ANPR Reference Manual. 

 

Click on the [Close] button to apply your changes. These settings 

will remain active until the application is closed or until the engine 

in use is replaced with another one from the drop-down list. When 

you exit the application, the changes will be lost and the values will 

revert to the ones saved in the gxsd.dat configuration file. 

 

Clicking on the [Save Properties] button will write the current values 

of each property into the gxsd.dat configuration file. This feature 

requires write permissions to the gxsd.dat file. The default values 

of an engine can be reset by reinstalling (uninstalling and installing) 

it, check it here how to do that. This function works only with ANPR 

properties as the MMR properties are read only. 

  

ANPR Settings 

MMR Settings 

https://adaptiverecognition.com/app/uploads/DOC/Software/Carmen/ANPR/carmen_anpr_reference_manual.pdf
https://adaptiverecognition.com/app/uploads/DOC/Software/Carmen/engine_manager_pro_user_manual.pdf
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Demo Preferences 

Contains various configuration options related to the demo software. 

By clicking this menu item, the following pop-up window will appear: 

Auto-Log: 

If checked, the results will be logged automatically.  

Find All Plates: 

If checked, the engine will search for all plates in the 

image that conform to the set parameters. 

Find Empty ADR 

If checked, the engine will search for the Empty ADR 

plates as well. 

Loop (toggle:L): 

If checked, the program continuously repeats 

processing of the specified image sequence/folder. 

Process Sample Image At Start-Up: 

If checked, the engine will process the specified 

sample image right after application start-up. 

Real plate frame drawing 

If checked, the real plate will be framed. 

Show ROI 

If checked, the set ROI will be visible on the image. 

Show ROU 

If checked, the set ROU will be visible on the image. 

Sample Image: 

This field shows the file that is loaded into ADI upon 

starting the application. 

Log Directory: 

Displays the directory, where the log file will be saved. Click […] button to specify another directory. 

The default folder is: “installation folder / logs” 

  

MMR engine is installed 

MMR engine is not installed 
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Auto-Process (toggle: Space): 

If checked, the application runs through the images and do ANPR on them automatically. 

 

Auto-Process Delay(ms): 

Type or use the arrows to adjust the amount of delay (in milliseconds) before the next image is loaded 

during Auto-Process. 

Font Family: Select the font style of the Result Tree (LPR details in the upper right corner of the ADI 

screen). 

Read MMR automatically: (can be checked only in case if you have any MMR engine installed). 

If checked, ADI demo will give you back the MMR results automatically. 

 

 

Process Menu 
The Process menu contains the following menu items:  

 

 

Click Next Image (N) or Previous Image (P) to navigate between the images. Alternatively, you may 
also use the N/P keys on the keyboard or simply click once on the image. 

 

  

 

If ‘Auto-Process’ is on, you will not be able to examine the individual results, even if there is 
no more image to processing. You must set it back to ‘Manual’. You can do it by clicking on 
the image and then pressing the ‘space’ on the keyboard. 

 

MMR engines need separate MMR licenses and must be the same region as ANPR license 
to be able to work together. GEN MMR engine can work with every ANPR engines (except 
GEN ANPR engine, which is not capable to run with any MMR engine) 
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Help Menu 
The Help menu contains the following menu items: 

 
 

User Manual: Opens this User Manual. 

About: Provides the license, version, and copyright information for the installed application. 
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Set ROI/ROU on the image 
From CARMEN® 7.3.1.26 there is a possibility to set the ROI/ROU properties on the image which is 

loaded to ADI Demo application. 

Steps: 
- Press CTRL+I (for ROI) or CTRL+U (for ROU) 
- Start clicking the points of the polygon 

ROI 

   
 

   
In written form: 206,95;943,106;975,508;183,541;342,314 
 
ROU 

   
 

   
In written form: 25,11;386,14;464,233;213,626;33,623 
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This is how it looks like if you are using ROI and ROU at the same time: 

 
 

 
 

- Once you have done, press CTRL+R (for both property) 
 

 

 

 

  

 

ROU is the stronger property so if there is ROU and ROU on the same part of the image. The 
engine will not search on that area! 

 

The property will be saved into the set property, but if you would like to save them to GXSD.DAT 
as well, do not forget to press Save Properties button in the Edit -> Demo Preferences menu 

 

Currently this function is capable to draw/save only one polygon for one property. 
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ANPR Result Tree 
The ANPR Result Tree is located to the right of the input image display area. It is divided into three 

main sections. 

 

1.  License plate result:  

Provides a detailed summary of the recognized image: 

• Text(ASCII): alphanumeric license plate text in ASCII 

characters 

• Plate type: category of the license plate 

• Confidence: overall confidence level (%) of the plate. 

• Type: code containing country/state ID of the plate. 

• Color: color of the dedicated area of the license plate. 

• BkColor: background color of license plate text. 

• Dedicated Area Color: color of dedicated area in RGB format 

• Frame: pixel coordinates of the plate corners. 

Only available if MMR is enabled! 

• Make&Model: the recognized vehicle Make and Model data 

• Category: the recognized vehicle category 

• Color: the color of the recognized vehicle 

• MMR Confidence: overall MMR confidence 

• MMR Time: MMR processing time in milliseconds 

 

2. Characters: 

Individual details for each recognized character. Ordered from left to right than up to down. 

• Code: unicode character ID 

• Confidence: confidence level (%) of the overall plate 

• Color: color of the character 

• BkColor: background color of character 

• Frame: pixel coordinates of the character corners 
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3. Tips: 

List of preliminary results from which the engine assembled the result. 

• Code: unicode character ID 

• Confidence: confidence level (%) of the overall plate 

• Color: color of the character 

• BkColor: background color of character 

• Frame: pixel coordinates of the character corner 

 

 

The application puts a frame around the image area, where it has located a license plate. 

 

When ADI is not in automatic mode, and it encounters an individual image with multiple plates, it will 

display all results from that image in the same result tree (if Find-All-Plates is checked in Edit -> Demo 

Preferences). 
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ANPR Data 
Results of the ANPR process are displayed in the log section in the bottom part of the screen. The log 

contains the following data: 

- Path: location of the image file. 

- Plate Text: alphanumeric license plate text. 

- Plate Text (ASCII): alphanumeric license plate text in ASCII characters 

- Plate category: category of the license plate. 

- Country/State ISO 3166-1 alpha-3 country code. 

- Confidence: overall confidence level of the plate. 

- Frame: pixel coordinates of the corners of the license plate. 

- Character Size: average height of the characters in pixels. 

- Text Background: background color of text in RGB format. 

- Text Color: character color in RGB format. 

- Dedicated Color: color of dedicated area in RGB format. 

- ANPR Time(ms): ANPR processing time in milliseconds. 

 
Only in case if MMR reading is enabled in Demo Preferences and there is an ANPR result. 

- Make&Model: the recognized vehicle Make and Model data 

- Category: the recognized vehicle category 

- Color: the color of the recognized vehicle 

- MMR Confidence: overall MMR confidence 

- MMR Time(ms): MMR processing time in milliseconds 

If you need more information about MMR please check this document: MMR Brief Description. 

 

 

 

  

 

The table above can be saved in a semi-colon delimited log file by clicking File/Save Log. 

By clicking a data row, the corresponding image and its result tree will appear above the log. 

https://adaptiverecognition.com/app/uploads/DOC/Software/Carmen/MMR/mmr_brief_description.pdf
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Data Logging 
 

The application saves each ANPR process in a log file. 

Naming format of the log file:  

ADI_yyyy-mm-dd_hhmm_sss.log (ADI_Year-Month-Day_HourMinute_Second.log) 

E.g.: ADI_2012-07-09_1712_001 

 

If the date changes, the process of the automatic logging continues in a different log file. 

When saving a log file, a separate anpr file with the same name will also be created in the same 

directory that contains the property settings of the currently used engine. 

 

Format of the log file: 

UTF16 (LE) encoding 

Semicolon separated values 

First Line: header with information in the following order: 

#;Path;Plate Text;Plate Text (ASCII);Plate category;Country/State;Confidence;Frame;Character 
Size;Text Background;Text Color;Dedicated Area Color;ANPR 
Time(ms);Make&Model;Category;Color;MMR confidence;MMR Time(ms); 
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Contact Information 
 
 
Headquarters:      Service Address: 

Adaptive Recognition Hungary  Inc.   Adaptive Recognition Hungary  Inc. 

Alkotás utca 41 HU-     Ipari Park HRSZ1113/1 HU 

1123 Budapest Hungary          2074 Perbál Hungary 

Phone: +36 1 201 9650         Phone: +36 1 2019650 

Fax: +36 1 201 9651             E-mail: rmarequest@adaptiverecognition.com 

Web: adaptiverecognition.com 

 

 

Adaptive Recognition Technical Support System (ATSS) is designed to provide you with the fastest 

and most proficient assistance to get you back to business quickly. 

For further technical information about our products, please visit our official website. 

 

Information regarding hardware, software, manuals, and FAQ are easily accessible for customers who 

previously registered to enter the dedicated ATSS site. Besides offering assistance, the site is also 

designed to provide maximum protection while managing your business information and the technical 

solutions utilized. 

 

New User 

If this is your first online support request, please create an account by clicking on this link. 

 

Returning User 

All registered ATSS customers receive a personal access link via email. If you previously received a 

confirmation message from ATSS, it contains the embedded link that allows you to enter the support 

site securely. 

 

If you need assistance with login or registration, please contact atsshelp@adaptiverecognition.com. 

 

mailto:rmarequest@adaptiverecognition.com
https://adaptiverecognition.com/
http://atssregistration.arh.hu/
http://atssregistration.arh.hu/
mailto:atsshelp@adaptiverecognition.com
mailto:atsshelp@adaptiverecognition.com

